Auteur Sujet: Debian + NVIDIA : NVRM: RmInitAdapter failed!  (Lu 3301 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Tawal

  • Archives
  • Members
  • *
  • Messages: 953
  • Le savoir n'a d'intérêt que si on le transmet.
Debian + NVIDIA : NVRM: RmInitAdapter failed!
« le: janvier 07, 2017, 16:56:12 »
Bonjour  :AAC

Depuis la nouvelle année, je subis un problème concernant le pilote de ma carte graphique : il ne fonctionne plus !

Dans le syslog, je trouve ce genre d'erreur : NVRM: RmInitAdapter failed!

J'ai regardé un peu sur le net pour trouver une solution mais sans succès.

Que j'installe le pilote depuis la logithèque ou depuis le site NVIDIA, rien à faire, le serveur X ne se lance pas.

Quelqu'un pour de l'aide ?

Merci  :AAN

Edit : Ma carte graphique : NVIDIA GeForce 7300
Mon système : Debian oldstable (Wheezy)
« Modifié: janvier 07, 2017, 16:57:30 par Tawal »
Puisque la science n'est pas infuse, elle se diffuse !

Security-X

Debian + NVIDIA : NVRM: RmInitAdapter failed!
« le: janvier 07, 2017, 16:56:12 »

En ligne igor51

  • Admin
  • Mega Power Members
  • *****
  • Messages: 10275
Re : Debian + NVIDIA : NVRM: RmInitAdapter failed!
« Réponse #1 le: janvier 07, 2017, 17:00:46 »
Hello

Quel driver utilises-tu ? (dpkg -l)

Normalement celui-la devrait fonctionner nvidia-legacy-304xx-driver il te demandera p-e de générer un xorg.conf avec nvidia-xconfig

Hors ligne Tawal

  • Archives
  • Members
  • *
  • Messages: 953
  • Le savoir n'a d'intérêt que si on le transmet.
Re : Debian + NVIDIA : NVRM: RmInitAdapter failed!
« Réponse #2 le: janvier 07, 2017, 17:05:33 »
Salut igor51 :AAC

Avant le problème, j'utilisais le pilote constructeur 304.125

J'ai essayé avec le pilote dont tu parles : négatif
De même avec nvidia-glx (recommandé par nvidia-detect).
Et encore de même avec le dernier pilote constructeur 304.134

Merci :AAN
Puisque la science n'est pas infuse, elle se diffuse !

En ligne igor51

  • Admin
  • Mega Power Members
  • *****
  • Messages: 10275
Re : Debian + NVIDIA : NVRM: RmInitAdapter failed!
« Réponse #3 le: janvier 07, 2017, 17:08:47 »
Je crois que j'ai jamais vu réellement fonctionner celui de nvidia....
Il faut bien dégager les précédents drivers avant d'installer les nouveaux.

T'a essayé de générer un xorg.conf pour forcer un driver spécifique ?

Hors ligne Tawal

  • Archives
  • Members
  • *
  • Messages: 953
  • Le savoir n'a d'intérêt que si on le transmet.
Re : Debian + NVIDIA : NVRM: RmInitAdapter failed!
« Réponse #4 le: janvier 07, 2017, 17:15:04 »
Oui, j'ai bien dégagé l'ancien pilote avant d'en installer un nouveau pour tester ;)

J'ai aussi essayé de générer un xorg.conf mais dès que j'active un pilote NVIDIA, boum, les erreurs kernel reviennent et le pilote ne fonctionne pas du tout.

J'ai aussi vérifié que mes linux-headers soient bien ceux correspondant à mon kernel.

Bizarrement, quand je ré-installe un pilote propriètaire, je ne peux plus construire le module dkms (celui qui permet une "réinstallation auto du pilote lors du changement de kernel).

Merci encore :AAC
Puisque la science n'est pas infuse, elle se diffuse !

Hors ligne Tawal

  • Archives
  • Members
  • *
  • Messages: 953
  • Le savoir n'a d'intérêt que si on le transmet.
Re : Debian + NVIDIA : NVRM: RmInitAdapter failed!
« Réponse #5 le: janvier 07, 2017, 19:05:23 »
Re,

Aïe, je crois bien que c'est un problème matériel, mais je n'en suis pas sûr (un bout d'espoir ?  :-\)

Code: (Xorg.0.log) [Sélectionner]
[    32.978] (EE) [drm] failed to open device
[    32.978] (EE) No devices detected.
[    32.978]
Fatal server error:
[    32.978] no screens found

Ces erreurs sont produites lorsque j'active un pilote quelconque : nvidia, nouveau etc ...    >:(
Puisque la science n'est pas infuse, elle se diffuse !

Hors ligne Tawal

  • Archives
  • Members
  • *
  • Messages: 953
  • Le savoir n'a d'intérêt que si on le transmet.
Re : Debian + NVIDIA : NVRM: RmInitAdapter failed!
« Réponse #6 le: janvier 16, 2017, 19:37:33 »
Plop,

Je reviens car j'en suis toujours au même point.

J'ai essayé plusieurs pilotes propriétaires (du plus récent à quelques anciens) + les pilotes des dépôts.
Rien à faire.

J'ai aussi réinstallé mon serveur X, me reste que le kernel a changer pour voir.
Mais bon quitte à en arriver là autant passer de la debian oldstable à la stable.
Ce qui est prévu.

Mais avant, j'aimerais pouvoir checker ma carte graphique.
Quel moyen ai-je pour vérifier que le matériel est sain ou pas ? (sachant que je suis sur un portable)

Merci :AAN

Edit :
Petit flash back mémoire : le pourquoi je suis en oldstable.
J'avais tenté d'installer la version stable de Debian mais j'avais buté sur l'installation du driver Nvidia.
Je crois bien que le problème est similaire ...

Je vais tester un "old" kernel et reviens écrire des news.
Thanks a lot. :AAN
« Modifié: janvier 17, 2017, 21:49:46 par Tawal »
Puisque la science n'est pas infuse, elle se diffuse !

Hors ligne Tawal

  • Archives
  • Members
  • *
  • Messages: 953
  • Le savoir n'a d'intérêt que si on le transmet.
Re : Debian + NVIDIA : NVRM: RmInitAdapter failed!
« Réponse #7 le: janvier 20, 2017, 18:31:29 »
Re,

Bon, ça ne semble pas facile d'installer un ancien kernel  :-[
$ uname -r
3.2.0-4-686-pae
Le seul kernel plus vieux que je trouve dans mes dépôts est le 3.16.0-0.bpo.4-686-pae (image et headers compris)
Or quand je veux l'installer, je me retrouve avec des dépendances cassées sur ce même kernel !

Je n'ai pas fait l'opération car il me demandait de désinstaller la suite apparmor ainsi que le paquet initramfs-tools.
Apparmor pas grave, l'autre je ne le sens pas.
Je crains bien de me retrouver avec un système non-bootable.

Un peu d'aide, s'il vous plaît ?

 :AAN
Puisque la science n'est pas infuse, elle se diffuse !

Hors ligne Tawal

  • Archives
  • Members
  • *
  • Messages: 953
  • Le savoir n'a d'intérêt que si on le transmet.
Re : Debian + NVIDIA : NVRM: RmInitAdapter failed!
« Réponse #8 le: janvier 24, 2017, 12:06:34 »

Erreur de ma part le 3.16 est plus récent que mon 3.2 évidemment !  :oups:

J'ai quand même essayé de "downgrader" mon kernel en forçant la version actuelle à une version antérieure (je suis passé de la 3.2-84 à la 3.2-78)
J'ai fait ça pour tout les paquets concernant le kernel et l'installation d'un pilote NVIDIA.
Mais quand je veux installer un pilote proprio, j'ai un message comme quoi il ne trouve pas les sources correspondant à mon kernel.
J'ai pourtant "downgradé" les sources aussi ! Étrange ...

Autre chose : j'ai lancé un installateur debian, le premier écran où on a le choix entre les différentes installations (graphique, expert etc) est illisible (constitué de gros caractères même pour le fond noir et le cadre bleu).
Passé cet écran, l'affichage redevient normal (vga) !

Qu'en pensez-vous ?
Y-a-t-il un docteur dans l'assistance ?   :P

 :AAN
Puisque la science n'est pas infuse, elle se diffuse !

En ligne igor51

  • Admin
  • Mega Power Members
  • *****
  • Messages: 10275
Re : Debian + NVIDIA : NVRM: RmInitAdapter failed!
« Réponse #9 le: février 12, 2017, 10:23:54 »
Bonjour Tawal,

Désolé, beaucoup de temps à passer.

Le problème est que tu mélanges pas mal de versions sur un même système ce qui implique que certaines choses sont un état un peu inconsistant.
Le fait de mélanger les paquets NVIDIA avec les autres créent des problèmes.

Pour ta carte, il te faut, je pense, déjà passer proprement sur une stable (ça doit être jessie actuellement) puis installer https://packages.debian.org/jessie/nvidia-legacy-304xx-driver mais il faut vérifier qu'il ne reste plus rien du driver proprio nvidia (driver + fichier de conf tel que xorg.conf)

Attention, même avec le --purge, les modifications manuelles ne sont pas toujours supprimées.
 

Hors ligne Tawal

  • Archives
  • Members
  • *
  • Messages: 953
  • Le savoir n'a d'intérêt que si on le transmet.
Re : Debian + NVIDIA : NVRM: RmInitAdapter failed!
« Réponse #10 le: mars 12, 2017, 14:41:44 »
Bonjour igor51,

Désolé aussi, beaucoup de temps a passé :(



Pour ma carte, je pense qu'elle est défectueuse.
En effet elle avait tendance a bien chauffer en la sollicitant (90° et +)

J'ai bien tenté des installations "propres" des drivers Nvidia, propriétaire ou libre : nada.

Le pourquoi du comment je suis en oldstable est que lorsque j'avais tenté d'installer Jessie (version stable), je n'arrivais pas à installer de pilote pour ma carte ...
Au point où j'en suis plus rien ne m'empêche de passer à la version stable de Debian.
Même si ça ne résout pas le problème de la CG, je serais un peu plus "à la page".

Merci de tes conseils :AAN
Je reviendrai dire des nouvelles sous la version stable.

Dans un peu de temps quand même, je suis pas mal occupé en ce moment.

@+  :AAC
Puisque la science n'est pas infuse, elle se diffuse !

Tags: